Problem:

When migrating Xray data to Jira Cloud using JCMA, it may take some time for your migration to move from 0%. 

Possible Causes:

During the migration of Xray data to Jira Cloud with JCMA, it may take some time for your migration to move from 0%.  This delay occurs because Xray is in the process of uploading data to JCMA. The status tracker stays at 0% until the configuration of data on the cloud side begins.

It's important to note that this initial 0% doesn't imply a stuck migration; rather, it indicates that the cloud configuration phase hasn't been initiated yet.  The duration of the migration is primarily influenced by the size of the data area being transferred, with attachments and the number of test runs having the most significant impact on the Xray data area size.

To provide a clearer picture of the Xray migration process, it unfolds in the following steps:

  1. Jira migration completes.
  2. Xray migration starts.
  3. Xray exports all data on the server side, which can take a while depending on the size of the data footprint, and then it is uploaded to JCMA.
  4. All the data is then downloaded from JCMA and set up on Xray Cloud.

In summary, the temporary 0% progress is part of the normal process, signifying the ongoing data upload phase before the subsequent configuration on the cloud side.

Solution:

If the migration has been on hold for some time, please do not stop the migration. There's a possibility that the Xray migration is still actively exporting data from the Server side to the Cloud. 

Therefore, if you want to check if there are any problems with your migration, please create a new ticket on our Service Desk portal: Migration Technical Support. and include the following information:

  • A Jira Support.zip containing the migration logs.

This way, we can verify what happened. Please follow the steps found in this Jira documentation to Create a Support Zip.

  • Provide the Cloud URL of the destination and the migration name

Then, we can check if the migration reaches out to the Xray Cloud side or not. 

  • Please inform us which option in JCMA you choose to migrate. "Migrate all data" or "Choose what to migrate"?
  • Kindly include a screenshot showing the Server-side report.

To access it, on the server instance, System > cloud migration> click on the drop-down button > View details). (see example image below):



To access, please navigate to your Jira Server/DC Administration Manage Apps Xray → and on the left menu, click on Cloud Migration. On that page, you should add all the projects you added for that migration and then press Validate. After that, please take a screenshot like the example below.

 

 

 

 

 

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